The earlier service disruption has been fully resolved. System performance has stabilized, and all EdgeIQ services are operating normally. The recovery follows the restoration of AWS backbone services in the us-east-1 region and TimescaleDB Cloud.
We will continue to monitor system performance closely, but no further instability is expected. No data loss occurred, and all queued operations have been successfully processed. Thank you for your patience and understanding throughout this incident.
Posted Oct 21, 2025 - 06:34 UTC
Monitoring
We are continuing to monitor ongoing system performance issues following the earlier AWS us-east-1, TimescaleDB Cloud, and Aiven Cloud disruptions. All core EdgeIQ systems remain operational, but some users may still experience occasional spikes in latency or brief service disruptions.
Our engineering team is actively tracking system metrics and working to maintain stability as upstream services fully recover. No data loss is expected, and queued data continues to process as intended. We will provide further updates as the situation evolves.
Our team is actively monitoring the situation as AWS and Timescale continue recovery efforts. While some users may still encounter temporary instability, we do not expect any data loss, and all queued data will be fully processed once systems stabilize. We appreciate your patience as we work to restore full reliability.
Posted Oct 20, 2025 - 11:35 UTC
This incident affected: API, Coda & MQTT Connectivity, Orchestration and Automation, Management Web Application, and HTTP Push and Polling Ingest.